Squid Web代理缓存arrayShrink()函数远程拒绝服务漏洞

2008-04-17T00:00:00
ID SSV:3184
Type seebug
Reporter Root
Modified 2008-04-17T00:00:00

Description

BUGTRAQ ID: 28693 CVE(CAN) ID: CVE-2008-1612

Squid是一个高效的Web缓存及代理程序,最初是为Unix平台开发的,现在也被移植到Linux和大多数的Unix类系统中,最新的Squid可以运行在Windows平台下。

Squid的arrayShrink()函数操控系统内存中所储存的缓存对象的HTTP头的方式存在漏洞,攻击者可以利用这个漏洞导致squid子进程退出,这会中断已有连接,导致代理服务不可以。

Squid父进程会启动一个新的子进程,因此这种攻击仅会导致临时的拒绝服务。这个漏洞是由于没有正确地修复CVE-2007-6239中所述漏洞而导致的。

Squid Web Proxy Cache 3 beta Squid Web Proxy Cache 2.0 - 2.6.STABLE17 RedHat


RedHat已经为此发布了一个安全公告(RHSA-2008:0214-01)以及相应补丁: RHSA-2008:0214-01:Moderate: squid security update 链接:<a href=https://www.redhat.com/support/errata/RHSA-2008-0214.html target=_blank>https://www.redhat.com/support/errata/RHSA-2008-0214.html</a>

Squid

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

<a href=http://www.squid-cache.org/Versions/v2/2.6/changesets/11882.patch target=_blank>http://www.squid-cache.org/Versions/v2/2.6/changesets/11882.patch</a> <a href=http://www.squid-cache.org/Versions/v2/2.6/squid-2.6.STABLE19.tar.gz target=_blank>http://www.squid-cache.org/Versions/v2/2.6/squid-2.6.STABLE19.tar.gz</a>