phpMyAdmin $_REQUEST参数SQL注入漏洞

2008-03-06T00:00:00
ID SSV:2981
Type seebug
Reporter Root
Modified 2008-03-06T00:00:00

Description

BUGTRAQ ID: 28068

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

phpMyAdmin使用$_REQUEST而不是$_GET和$_POST变量作为其参数来源,并且在SQL查询中未经过滤便使用了参数,如果用户受骗访问了恶意网站的话,就可能导致SQL注入攻击。

phpMyAdmin phpMyAdmin < 2.11.5 厂商补丁:

phpMyAdmin

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

<a href=http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.11.5-all-languages.tar.bz2?download target=_blank>http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.11.5-all-languages.tar.bz2?download</a>