Firebird关系数据库Username参数远程栈溢出漏洞

2008-01-30T00:00:00
ID SSV:2877
Type seebug
Reporter Root
Modified 2008-01-30T00:00:00

Description

BUGTRAQ ID: 27467

Firebird是一款提供多个ANSI SQL-92功能的关系型数据库,可运行在Linux、Windows和各种Unix平台下。

Firebird在处理畸形的用户请求时存在漏洞,远程攻击者可能利用此漏洞控制服务器。

如果远程攻击者向Firebird服务器提交了超长用户名的话,就可能触发栈溢出,导致执行任意指令。

Firebird Firebird 2.1 Beta 1 Firebird Firebird 2.1 Alpha 1 Firebird Firebird 2.0.3 Firebird Firebird 2.0.2 Firebird Firebird 2.0.1 Firebird Firebird 2.0.0 Firebird Firebird 1.5.4 Firebird Firebird 1.0.3 厂商补丁:

Firebird

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

<a href=http://downloads.sourceforge.net/firebird/Firebird-2.1.0.17735-ReleaseCandidate1.tar.bz2 target=_blank>http://downloads.sourceforge.net/firebird/Firebird-2.1.0.17735-ReleaseCandidate1.tar.bz2</a>