Samba NMBD登录请求远程溢出漏洞

2007-11-17T00:00:00
ID SSV:2434
Type seebug
Reporter Root
Modified 2007-11-17T00:00:00

Description

BUGTRAQ ID: 26454 CVE(CAN) ID: CVE-2007-4572

Samba是一套实现SMB(Server Messages Block)协议、跨平台进行文件共享和打印共享服务的程序。

Samba的nmbd在处理GETDC登录服务器请求时存在缓冲器溢出漏洞,可能导致非预期的服务器行为。

如果远程攻击者发送了畸形的GETDC请求的话就可以触发这个漏洞,但无法利用这个溢出执行任意指令,在大多数情况下也不会导致Samba服务器崩溃。仅在将Samba服务器配置为主或备份域控制器时才会出现这个漏洞。

Samba 3.0.0 - 3.0.26a 临时解决方法:

  • 在服务器的smb.conf文件中禁用domain logons和domain master选项。

厂商补丁:

RedHat

RedHat已经为此发布了安全公告(RHSA-2007:1017-01、RHSA-2007:1016-01、RHSA-2007:1013-01)以及相应补丁: RHSA-2007:1017-01:Critical: samba security update 链接:<a href="https://www.redhat.com/support/errata/RHSA-2007-1017.html" target="_blank">https://www.redhat.com/support/errata/RHSA-2007-1017.html</a>

RHSA-2007:1016-01:Critical: samba security update 链接:<a href="https://www.redhat.com/support/errata/RHSA-2007-1016.html" target="_blank">https://www.redhat.com/support/errata/RHSA-2007-1016.html</a>

RHSA-2007:1013-01:Critical: samba security update 链接:<a href="https://www.redhat.com/support/errata/RHSA-2007-1013.html" target="_blank">https://www.redhat.com/support/errata/RHSA-2007-1013.html</a>

Samba

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

<a href="http://us1.samba.org/samba/ftp/patches/security/samba-3.0.26a-CVE-2007_-4572.patch" target="blank">http://us1.samba.org/samba/ftp/patches/security/samba-3.0.26a-CVE-2007-4572.patch</a>