phpMyAdmin setup.php跨站脚本执行漏洞

2007-10-18T00:00:00
ID SSV:2310
Type seebug
Reporter Root
Modified 2007-10-18T00:00:00

Description

BUGTRAQ ID: 26020

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

phpMyAdmin的setup.php文件没有正确地验证某些用户输入参数,允许远程攻击者通过提交恶意的URI请求执行跨站脚本攻击。

phpMyAdmin phpMyAdmin 2.11.1 目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

<a href="http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/MAINT_2_11_1/phpMyAdmin/scripts/setup.php?r1=10637&r2=10748&view=patch" target="_blank">http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/MAINT_2_11_1/phpMyAdmin/scripts/setup.php?r1=10637&r2=10748&view=patch</a>

                                        
                                            
                                                http://domain/phpMyAdmin-2.11.1/scripts/setup.php?&gt;'&quot;&gt;&lt;script&gt;alert('xss')&lt;/script&gt;