FFmpeg Real Media文件解析内存破坏远程代码执行漏洞

2011-04-08T00:00:00
ID SSV:20443
Type seebug
Reporter Root
Modified 2011-04-08T00:00:00

Description

BUGTRAQ ID: 47149 CVE ID: CVE-2011-0722

FFmpeg是一个自由软件,可以执行音讯和视讯多种格式的录影、转档、串流功能,包含了libavcodec ─这是一个用于多个专案中音讯和视讯的解码器函式库,以及 libavformat ——一个音讯与视讯格式转换函式库。

FFmpeg在解析畸形多媒体文件时存在内存破坏远程代码执行漏洞,远程攻击者可利用此漏洞在受影响应用程序中执行任意代码,造成拒绝服务。

Ubuntu Linux 9.x Ubuntu Linux 8.x Ubuntu Linux 10.x FFmpeg FFmpeg <= 0.5.4 厂商补丁:

FFmpeg

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://ffmpeg.sourceforge.net/