Linux Kernel ext4_decode_error函数空指针引用拒绝服务漏洞

2010-01-06T00:00:00
ID SSV:15184
Type seebug
Reporter Root
Modified 2010-01-06T00:00:00

Description

CVE ID: CVE-2009-4308

Linux Kernel是开放源码操作系统Linux所使用的内核。

Linux Kernel的ext4子系统的fs/ext4/super.c文件中的ext4_decode_error()函数中存在空指针引用错误。用户受骗加载了特制的只读文件系统就可以触发这个漏洞,导致拒绝服务的情况。

Linux kernel 2.6.x Linux


目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=78f1ddbb498283c2445c11b0dfa666424c301803