Multiple Reflected XSS in ResAds version 1.0.1 WordPress plugin

Type securityvulns
Reporter Securityvulns
Modified 2015-10-26T00:00:00


Vulnerability title: Multiple Reflected XSS in ResAds version 1.0.1 WordPress plugin CVE: CVE-2015-7667 Vendor: WordPress web-mv Product: ResAds Affected version: 1.0.1 Fixed version: 1.0.2 Reported by: Iberia Medeiros

Vulnerability Details:

It was discovered that no protection against multiple reflected XSS attacks was implemented, resulting in an attacker being able to retrive user data from end user, such as session cookies.

The ResAds version 1.0.1 WordPress plugin is vulnerable to 2 reflected XSS vulnerabilities. The templates/admanagement/admanagement.php and templates/adspot/adspot.php files are vulnerable to Cross-site.scripting (XSS) attacks via $_REQUEST['page'] parameter.

System affected:

Any system that access to a web site developed by WordPress CMS version 4.3.1 or earlier and uses the ResAds version 1.0.1.



Update to ResAds version 1.0.2 plugin.

Disclosure Timeline:

Vendor notification: September 27, 2015 Vendor fixed vulnerability: September 29, 2015 Public advisory: September 29, 2015 Public disclosure: October 4, 2015