[SECURITY ANNOUNCEMENT] CVE-2015-0225

2015-05-12T00:00:00
ID SECURITYVULNS:DOC:32104
Type securityvulns
Reporter Securityvulns
Modified 2015-05-12T00:00:00

Description

CVE-2015-0225: Apache Cassandra remote execution of arbitrary code

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected: Cassandra 1.2.0 to 1.2.19 Cassandra 2.0.0 to 2.0.13 Cassandra 2.1.0 to 2.1.3

Description: Under its default configuration, Cassandra binds an unauthenticated JMX/RMI interface to all network interfaces. As RMI is an API for the transport and remote execution of serialized Java, anyone with access to this interface can execute arbitrary code as the running user.

Mitigation: 1.2.x has reached EOL, so users of <= 1.2.x are recommended to upgrade to a supported version of Cassandra, or manually configure encryption and authentication of JMX, (seehttps://wiki.apache.org/cassandra/JmxSecurity). 2.0.x users should upgrade to 2.0.14 2.1.x users should upgrade to 2.1.4 Alternately, users of any version not wishing to upgrade can reconfigure JMX/RMI to enable encryption and authentication according to https://wiki.apache.org/cassandra/JmxSecurityor http://docs.oracle.com/javase/7/docs/technotes/guides/management/agent.html

Credit: This issue was discovered by Georgi Geshev of MWR InfoSecurity