CVE-2015-1773 Apache Flex reflected XSS vulnerability

2015-05-12T00:00:00
ID SECURITYVULNS:DOC:32102
Type securityvulns
Reporter Securityvulns
Modified 2015-05-12T00:00:00

Description

CVE-2015-1773 Apache Flex reflected XSS vulnerability

Severity: Low

Vendor: The Apache Software Foundation

Versions Affected: All versions of Apache Flex before 4.14.1

Description: The asdoc tool produced JavaScript code that was vulnerable to a reflected XSS attack. A request with a specially crafted URL could execute malicious JavaScript in the user's web browser. The attacker would have to convince the user to click the attacker's crafted link.

This only affects the output of the 'asdoc' tool, not the output of the 'mxmlc' compiler or deployed Apache Flex applications.

Mitigation: Users should upgrade to the most recent version of Apache Flex and regenerate any local files produced by the asdoc tool. If you have made local modifications to the asdoc index.html file, such as altering the TITLE tags, you will need to make sure these are preserved.

Alternatively, apply the following changes to any already generated asdoc index.html files, as well as to the file asdoc/templates/index.html in any older Apache Flex SDKs http://bit.ly/apache-flex-asdoc-fix

Credit: Thanks to Radjnies Bhansingh of Securify BV for reporting this issue.

Tom Chiverton Apache Flex PMC