[ MDVSA-2014:116 ] file

2014-06-14T00:00:00
ID SECURITYVULNS:DOC:30805
Type securityvulns
Reporter Securityvulns
Modified 2014-06-14T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1


Mandriva Linux Security Advisory MDVSA-2014:116 http://www.mandriva.com/en/support/security/


Package : file Date : June 10, 2014 Affected: Business Server 1.0


Problem Description:

Updated file packages fix security vulnerabilities:

A flaw was found in the way file's Composite Document Files (CDF) format parser handle CDF files with many summary info entries. The cdf_unpack_summary_info() function unnecessarily repeatedly read the info from the same offset. This led to many file_printf() calls in cdf_file_property_info(), which caused file to use an excessive amount of CPU time when parsing a specially-crafted CDF file (CVE-2014-0237).

A flaw was found in the way file parsed property information from Composite Document Files (CDF) files. A property entry with 0 elements triggers an infinite loop (CVE-2014-0238).


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0237 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0238 http://advisories.mageia.org/MGASA-2014-0252.html


Updated Packages:

Mandriva Business Server 1/X86_64: a5dfce54828dd96daac16a55a02ffcc9 mbs1/x86_64/file-5.12-1.2.mbs1.x86_64.rpm d478bf550d758888fd1cfebcd88218a7 mbs1/x86_64/lib64magic1-5.12-1.2.mbs1.x86_64.rpm c71ec3847bde0886e059ec62aa61accc mbs1/x86_64/lib64magic-devel-5.12-1.2.mbs1.x86_64.rpm 288d35fcd1507c39de0c48a3cb260a7b mbs1/x86_64/lib64magic-static-devel-5.12-1.2.mbs1.x86_64.rpm 622fde9b5cf152b2070716c87f91d469 mbs1/x86_64/python-magic-5.12-1.2.mbs1.noarch.rpm 41b84c99bd263161a7d425862b64d63c mbs1/SRPMS/file-5.12-1.2.mbs1.src.rpm


To upgrade automatically use MandrivaUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/en/support/security/advisories/

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com


Type Bits/KeyID Date User ID pub 1024D/22458A98 2000-07-10 Mandriva Security Team <security*mandriva.com> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFTlsaxmqjQ0CJFipgRAhdfAKDSMmnMQGg3nf46S6Mi2SZjH2lO0gCdFrbu pHV6AAvPBgUhkd39IuLbQW8= =yVFD -----END PGP SIGNATURE-----