[SECURITY] CVE-2013-2187: Apache Archiva Cross-Site Scripting vulnerability

2014-05-04T00:00:00
ID SECURITYVULNS:DOC:30567
Type securityvulns
Reporter Securityvulns
Modified 2014-05-04T00:00:00

Description

CVE-2013-2187: Apache Archiva Cross-Site Scripting vulnerability

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected: - Archiva 1.3 to Continuum 1.3.6 - The unsupported versions Archiva 1.2 to 1.2.2 are also affected.

Description: A request that included a specially crafted request parameter could be used to inject arbitrary HTML or Javascript into the Archiva home page.

Mitigation: All users are recommended to upgrade to Archiva 2.0.1 or Archiva 1.3.8, which are not affected by this issue.

Archiva 2.0.0 and later is not affected by this issue.

References: http://archiva.apache.org/security.html