[ANN][SECURITY] ClassLoader manipulation issue confirmed for Struts 1 - CVE-2014-0114

2014-05-02T00:00:00
ID SECURITYVULNS:DOC:30528
Type securityvulns
Reporter Securityvulns
Modified 2014-05-02T00:00:00

Description

The Apache Struts project team confirms that Struts 1 in all versions is affected by a ClassLoader manipulation vulnerability similar to a recently fixed vulnerability in Struts 2 (CVE-2014-0112, CVE-2014-0094) [1].

This is a different underlying flaw. For future reference, please use CVE-2014-0114 in regards to this issue.

Struts 1 has had its End-Of-Life announcement one year ago. In a cross project effort, the Struts team is looking for a correction or mitigation path though. Please stay tuned for further information regarding a solution.

This is a cross-list posting. If you have questions regarding this report, please direct them to security@struts.apache.org only.

[1] http://struts.apache.org/release/2.3.x/docs/s2-021.html

-- Rene Gielen http://twitter.com/rgielen