[USN-1722-1] jQuery vulnerability

2013-02-18T00:00:00
ID SECURITYVULNS:DOC:29059
Type securityvulns
Reporter Securityvulns
Modified 2013-02-18T00:00:00

Description

========================================================================== Ubuntu Security Notice USN-1722-1 February 13, 2013

jquery vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10
  • Ubuntu 10.04 LTS

Summary:

jQuery could be made to expose sensitive information over the network.

Software Description: - jquery: JavaScript library for dynamic web applications

Details:

It was discovered that jQuery incorrectly handled selecting elements using location.hash, resulting in a possible cross-site scripting (XSS) issue. With cross-site scripting vulnerabilities, if a user were tricked into viewing a specially crafted page, a remote attacker could exploit this to modify the contents, or steal confidential data, within the same domain.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10: libjs-jquery 1.6.2-1ubuntu2.2

Ubuntu 10.04 LTS: libjs-jquery 1.3.3-2ubuntu1.2

In general, a standard system update will make all the necessary changes.

References: http://www.ubuntu.com/usn/usn-1722-1 CVE-2011-4969

Package Information: https://launchpad.net/ubuntu/+source/jquery/1.6.2-1ubuntu2.2 https://launchpad.net/ubuntu/+source/jquery/1.3.3-2ubuntu1.2

-- ubuntu-security-announce mailing list ubuntu-security-announce@lists.ubuntu.com Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce