Google App Enging SDK Code Execution Vulnerability (CVE 2011-1364)

2011-10-24T00:00:00
ID SECURITYVULNS:DOC:27204
Type securityvulns
Reporter Securityvulns
Modified 2011-10-24T00:00:00

Description

We recently identified an interesting code execution vulnerability in the Google App Engine SDK for Python. By combining a CSRF vulnerability in the administration web UI, with some other unique vulnerabilities we found in the Google python libraries, a remote hacker could gain remote code execution privileges on victim's machine. This vulnerability affects all operation systems running Google App Engine SDK for python (i.e. Windows, Mac OS, etc.).

Full advisory can be found at:

http://blog.watchfire.com/wfblog/2011/10/google-app-engine-cve-2011-1364.html

-Adish Adi Sharabani Security Strategist, Master Inventor, IBM