XSS Vulnerability in 1024cms Admin Control Panel v1.1.0 Beta (Master-cPanel Package)

2011-04-11T00:00:00
ID SECURITYVULNS:DOC:26083
Type securityvulns
Reporter Securityvulns
Modified 2011-04-11T00:00:00

Description

============================================================================================================ 1024cms Admin Control Panel v1.1.0 Beta (Master-cPanel Package) - Cross-Site Scripting Vulnerability ============================================================================================================

Software: 1024cms Admin Control Panel v1.1.0 Beta (master-cpanel package) Vendor: http://1024cms.org/ Vuln Type: Cross-Site Scripting Remote: Yes Local: No Discovered by: QSecure and Demetris Papapetrou Website: http://www.qsecure.com.cy Discovered: 15/03/2011 Reported: 29/03/2001 Disclosed: 07/04/2011

VULNERABILITY DESCRIPTION:

The scripts "/common/pages/lib/footer_login.php" and "/common/pages/lib/footer_loggedin.php" are prone to a cross-site-scripting vulnerability because they fail to properly sanitize user-supplied input in the "msg" parameter.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

PoC Exploit:

Note: PHNjcmlwdD5hbGVydCgnWFNTJyk7PC9zY3JpcHQ%2b = URL_Encoded(Base64_Encoded(XSS string))

/index.php?msg=PHNjcmlwdD5hbGVydCgnWFNTJyk7PC9zY3JpcHQ%2b