[ MDVSA-2011:036 ] mailman

2011-02-26T00:00:00
ID SECURITYVULNS:DOC:25793
Type securityvulns
Reporter Securityvulns
Modified 2011-02-26T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1


Mandriva Linux Security Advisory MDVSA-2011:036 http://www.mandriva.com/security/


Package : mailman Date : February 23, 2011 Affected: 2009.0, 2010.0, 2010.1, Corporate 4.0, Enterprise Server 5.0


Problem Description:

A vulnerability has been found and corrected in mailman:

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) full name or (2) username field in a confirmation message (CVE-2011-0707).

Packages for 2009.0 are provided as of the Extended Maintenance Program. Please visit this link to learn more: http://store.mandriva.com/product_info.php?cPath=149&products_id=490

The updated packages have been patched to correct this issue.


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0707


Updated Packages:

Mandriva Linux 2009.0: 47a36cb8bb5464358047e119a573f0fb 2009.0/i586/mailman-2.1.11-1.3mdv2009.0.i586.rpm 79afe7d6091352e440e02107ab466efe 2009.0/SRPMS/mailman-2.1.11-1.3mdv2009.0.src.rpm

Mandriva Linux 2009.0/X86_64: 3a07afa82cf9334e9d2cbd88208c578a 2009.0/x86_64/mailman-2.1.11-1.3mdv2009.0.x86_64.rpm 79afe7d6091352e440e02107ab466efe 2009.0/SRPMS/mailman-2.1.11-1.3mdv2009.0.src.rpm

Mandriva Linux 2010.0: 20c696c21b949cb810f055d3b3803a12 2010.0/i586/mailman-2.1.12-3.3mdv2010.0.i586.rpm 4e461a2eb191aa9665ae4c8723ac1b17 2010.0/SRPMS/mailman-2.1.12-3.3mdv2010.0.src.rpm

Mandriva Linux 2010.0/X86_64: 9997c9ffed7a9672c92282c73f187aa1 2010.0/x86_64/mailman-2.1.12-3.3mdv2010.0.x86_64.rpm 4e461a2eb191aa9665ae4c8723ac1b17 2010.0/SRPMS/mailman-2.1.12-3.3mdv2010.0.src.rpm

Mandriva Linux 2010.1: 3c4ec4ef441084a5011d9c10b441df56 2010.1/i586/mailman-2.1.13-1.3mdv2010.2.i586.rpm 2376bf5d3a1669352dfd8f11840bea55 2010.1/SRPMS/mailman-2.1.13-1.3mdv2010.2.src.rpm

Mandriva Linux 2010.1/X86_64: 3d6740a45395643aea20eaa55c584668 2010.1/x86_64/mailman-2.1.13-1.3mdv2010.2.x86_64.rpm 2376bf5d3a1669352dfd8f11840bea55 2010.1/SRPMS/mailman-2.1.13-1.3mdv2010.2.src.rpm

Corporate 4.0: 1ba9ef634bf145c569009dbc7f717f65 corporate/4.0/i586/mailman-2.1.6-6.5.20060mlcs4.i586.rpm d9e1706712003f86bcb18dcc0fbb9307 corporate/4.0/SRPMS/mailman-2.1.6-6.5.20060mlcs4.src.rpm

Corporate 4.0/X86_64: f151b2121b079b4821c2d88e276c1a19 corporate/4.0/x86_64/mailman-2.1.6-6.5.20060mlcs4.x86_64.rpm d9e1706712003f86bcb18dcc0fbb9307 corporate/4.0/SRPMS/mailman-2.1.6-6.5.20060mlcs4.src.rpm

Mandriva Enterprise Server 5: ecfdebbe4501d6d2ff60834f9050d9f7 mes5/i586/mailman-2.1.11-1.3mdvmes5.1.i586.rpm c828514e473947b0b21d90db6d5c56eb mes5/SRPMS/mailman-2.1.11-1.3mdvmes5.1.src.rpm

Mandriva Enterprise Server 5/X86_64: b6d9bfdaf7e2f33f942d1f3408eebb02 mes5/x86_64/mailman-2.1.11-1.3mdvmes5.1.x86_64.rpm c828514e473947b0b21d90db6d5c56eb mes5/SRPMS/mailman-2.1.11-1.3mdvmes5.1.src.rpm


To upgrade automatically use MandrivaUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com


Type Bits/KeyID Date User ID pub 1024D/22458A98 2000-07-10 Mandriva Security Team <security*mandriva.com> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFNZRSimqjQ0CJFipgRAgoHAKCFFWAwwIJOKZQ7LLy2Ys1vBKmJngCg3w7/ 0VY4v73uqXZ5zl5CMiIKH0o= =irx9 -----END PGP SIGNATURE-----