Security Advisory for Bugzilla 3.2.8, 3.4.8, 3.6.2, and 3.7.3

Type securityvulns
Reporter Securityvulns
Modified 2010-11-04T00:00:00




Bugzilla is a Web-based bug-tracking system used by a large number of software projects. The following security issues have been discovered in Bugzilla:

  • There is a way to inject both headers and content to users, causing a serious Cross-Site Scripting vulnerability.

  • It was possible to see graphs from Old Charts even if you did not have access to a particular product, and you could browse a particular URL to see all product names.

  • YUI 2.8.1, which shipped with Bugzilla starting with 3.7.x, contained a security vulnerability. The version of YUI shipped with Bugzilla 4.0rc1 and above has been updated to 2.8.2.

All affected installations are encouraged to upgrade as soon as possible.

Vulnerability Details

Class: HTTP Response Splitting Versions: Every Version Before 3.2.9, 3.4.9, 3.6.3, 4.0rc1 Fixed In: 3.2.9, 3.4.9, 3.6.3, 4.0rc1 Description: By inserting a certain string into a URL, it was possible to inject both headers and content to any browser that supported "Server Push" (mostly only Gecko-based browsers like Firefox). This could lead to Cross-Site Scripting vulnerabilities, and possibly other more dangerous security issues as well. References: CVE Number: CVE-2010-3172

Class: Information Leak Versions: 2.12 to 3.2.8, 3.4.8, 3.6.2, 3.7.3, 4.1 Fixed In: 3.2.9, 3.4.9, 3.6.3, 4.0rc1 Description: The Old Charts system generated graphs with predictable names into the "graphs/" directory, which also could be browsed to see its contents. This allowed unauthorized users to see product names and charted information about those products over time. References: CVE Number: CVE-2010-3764

Class: Cross-Site Scripting Versions: 3.7.1 to 3.7.3, 4.1 Fixed In: 4.0rc1 Description: YUI 2.8.1 was vulnerable to a Cross-Site Scripting vulnerability in certain .swf files. The YUI shipped with Bugzilla has been updated to 2.8.2. References:

Vulnerability Solutions

The fixes for these issues are included in the 3.2.9, 3.4.9, 3.6.3, and 4.0rc1 releases. Upgrading to a release with the relevant fixes will protect your installation from possible exploits of these issues.

If you are unable to upgrade but would like to patch just the individual security vulnerabilities, there are patches available for each issue at the "References" URL for each vulnerability.

Full release downloads, patches to upgrade Bugzilla from previous versions, and CVS/bzr upgrade instructions are available at:


The Bugzilla team wish to thank the following people/organizations for their assistance in locating, advising us of, and assisting us to fix this issue:

Frederic Buclin Byron Jones Max Kanat-Alexander Marc Schumann Michael Coates Philip Gillissen Masahiro Yamada

General information about the Bugzilla bug-tracking system can be found at:

Comments and follow-ups can be directed to the newsgroup or the support-bugzilla mailing list. has directions for accessing these forums. -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.10 (GNU/Linux) Comment: Using GnuPG with Fedora -

iEYEARECAAYFAkzR2h0ACgkQaL2D/aEJPK4b5wCeNl0ZgnrYVsqL+2c5Wn4gsHo0 vMwAnixlXSwrFw9ReV/mt8YAVmWlc7JE =aV4Q -----END PGP SIGNATURE-----