PolyPager 1.0rc10 (fckeditor) File Upload Security Issue

2010-05-13T00:00:00
ID SECURITYVULNS:DOC:23850
Type securityvulns
Reporter Securityvulns
Modified 2010-05-13T00:00:00

Description

PolyPager 1.0rc10 (fckeditor) Remote Arbitrary File Upload Vulnerability

Impact Security Bypass Where From remote Software PolyPager 1.0rc10

Description A security issue has been discovered in PolyPager, which can be exploited by malicious people to bypass certain security restrictions.

Access to the enabled FCKeditor component is not properly restricted, which can be exploited to e.g upload files of certain types.

The security issue is confirmed in version 1.0rc10 Other versions may also be affected.

Solution Restrict access to the plugins/fckeditor/editor/filemanager/connectors/ directory (e.g. via .htaccess)