[ MDVSA-2009:226 ] freeradius

2009-09-10T00:00:00
ID SECURITYVULNS:DOC:22450
Type securityvulns
Reporter Securityvulns
Modified 2009-09-10T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1


Mandriva Linux Security Advisory MDVSA-2009:226 http://www.mandriva.com/security/


Package : freeradius Date : September 10, 2009 Affected: Corporate 4.0


Problem Description:

A vulnerability has been found and corrected in freeradius:

The rad_decode function in FreeRADIUS before 1.1.8 allows remote attackers to cause a denial of service (radiusd crash) via zero-length Tunnel-Password attributes. NOTE: this is a regression error related to CVE-2003-0967 (CVE-2009-3111).

This update provides a solution to this vulnerability.


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3111


Updated Packages:

Corporate 4.0: 37f0dc23fdd28466d7a94db9ad445e36 corporate/4.0/i586/freeradius-1.0.4-2.5.20060mlcs4.i586.rpm e9f0aeb620f6c18f7abe8cd030ee5b45 corporate/4.0/i586/libfreeradius1-1.0.4-2.5.20060mlcs4.i586.rpm 5efc89f68a9ae3323f4d08db2db99c76 corporate/4.0/i586/libfreeradius1-devel-1.0.4-2.5.20060mlcs4.i586.rpm 7cfebad483805297740a24c630d959c4 corporate/4.0/i586/libfreeradius1-krb5-1.0.4-2.5.20060mlcs4.i586.rpm e9cfff1376db58a3dec1499bdada7d07 corporate/4.0/i586/libfreeradius1-ldap-1.0.4-2.5.20060mlcs4.i586.rpm 97d0dd301a51c5402d4fdedd113a4162 corporate/4.0/i586/libfreeradius1-mysql-1.0.4-2.5.20060mlcs4.i586.rpm 617dbfffff6ea9191afb7f9573e65883 corporate/4.0/i586/libfreeradius1-postgresql-1.0.4-2.5.20060mlcs4.i586.rpm 3a75efd86b69a5bb0ac240d1e7c2ae75 corporate/4.0/i586/libfreeradius1-unixODBC-1.0.4-2.5.20060mlcs4.i586.rpm a89677d75dc960fd619954eb53b4d749 corporate/4.0/SRPMS/freeradius-1.0.4-2.5.20060mlcs4.src.rpm

Corporate 4.0/X86_64: b4ac8ca1b8e9bca59c7f1a2b21386e65 corporate/4.0/x86_64/freeradius-1.0.4-2.5.20060mlcs4.x86_64.rpm 018ee9ffa0b73a5f5cf2b183f83deb5d corporate/4.0/x86_64/lib64freeradius1-1.0.4-2.5.20060mlcs4.x86_64.rpm 24f796932b9ffe79093351912a1c40e7 corporate/4.0/x86_64/lib64freeradius1-devel-1.0.4-2.5.20060mlcs4.x86_64.rpm adc0cba3f5d762c43c494aed2c2e4924 corporate/4.0/x86_64/lib64freeradius1-krb5-1.0.4-2.5.20060mlcs4.x86_64.rpm c21d434b39fca57615932c5e4c895459 corporate/4.0/x86_64/lib64freeradius1-ldap-1.0.4-2.5.20060mlcs4.x86_64.rpm b52370d5e13cb0e9534050e5f7e8a5a7 corporate/4.0/x86_64/lib64freeradius1-mysql-1.0.4-2.5.20060mlcs4.x86_64.rpm 8bdcfbb1740d3967b5ef909f14af32c9 corporate/4.0/x86_64/lib64freeradius1-postgresql-1.0.4-2.5.20060mlcs4.x86_64.rpm d376a3b411ecd4ed71c2289b2da536ae corporate/4.0/x86_64/lib64freeradius1-unixODBC-1.0.4-2.5.20060mlcs4.x86_64.rpm a89677d75dc960fd619954eb53b4d749 corporate/4.0/SRPMS/freeradius-1.0.4-2.5.20060mlcs4.src.rpm


To upgrade automatically use MandrivaUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com


Type Bits/KeyID Date User ID pub 1024D/22458A98 2000-07-10 Mandriva Security Team <security*mandriva.com> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFKqMYdmqjQ0CJFipgRAmWZAKDiWc30oc8TUdCK9qT5+svPaMOPzQCgm73G dGxi5xjHNGGtXkz/9cowb9A= =0yka -----END PGP SIGNATURE-----