Google Chrome MetaCharacter URI Obfuscation Vulnerability

2008-11-25T00:00:00
ID SECURITYVULNS:DOC:20919
Type securityvulns
Reporter Securityvulns
Modified 2008-11-25T00:00:00

Description

Advisory: Google Chrome MetaCharacter URI Obfuscation Vulnerability.

Version Affected: All Chrome/0.2.149.30 Chrome/0.2.149.29 Chrome/0.2.149.27

Description: Google chrome is vulnerable to URI Obfuscation vulnerability. An attacker can easily perform malicious redirection by manipulating the browser functionality. The link can not be traversed properly in status address bar.This could facilitate the impersonation of legitimate web sites in order to steal sensitive information from unsuspecting users. The URI specified with @ character with or without NULL character causes the vulnerability.

Proof of Concept: http://www.secniche.org/gcuri/index.html <http://www.secniche.org/gcuri> http://evilfingers.com/advisory/index.php

Detection: SecNiche confirmed this vulnerability affects Google Chrome on Microsoft Windows XP SP2 platform.The versions tested are:

Chrome/0.2.149.30 Chrome/0.2.149.29

Disclosure Timeline: Disclosed: 24 November 2008 Release Date. 24 November ,2008

Vendor Response: Reported to Google.

Credit: Aditya K Sood

Disclaimer: The information in the advisory is believed to be accurate at the time of publishing based on currently available information. Use of the information constitutes acceptance for use in an AS IS condition. There is no representation or warranties, either express or implied by or with respect to anything in this document, and shall not be liable for any implied warranties of merchantability or fitness for a particular purpose or for any indirect special or consequential damages.