Wikepage XSS vuln

2007-10-08T00:00:00
ID SECURITYVULNS:DOC:18138
Type securityvulns
Reporter Securityvulns
Modified 2007-10-08T00:00:00

Description

Sunday, 7 October 2007 Wikepage XSS vuln.

Vuln. discovered by : r0t Date: 7 October 2007 Vendor:http://www.wikepage.org/ affected versions:Wikepage Opus 13 2007.2 other versions also can be affected.

Wikepage contains a flaw that allows a remote Cross-Site Scripting attacks.Input passed to the "PageContent" and "PageName" parameter in "index.php" isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

note: Wikepage is derived from Tipiwiki2, so almost same structure, that vuln. you can find also in current Tipiwiki2.

Solution: Edit the source code to ensure that input is properly sanitised.

Posted by r0t at 17:59