eGov Content Manager Cross Site Scripting Vulrnability

2007-10-02T00:00:00
ID SECURITYVULNS:DOC:18102
Type securityvulns
Reporter Securityvulns
Modified 2007-10-02T00:00:00

Description

[HSC] eGov Content Manager Cross Site Scripting Vulrnability

The eGov Manager was designed to simplify the efforts of government staffers who are responsible for posting public documents, news updates, events, managing staff directories and online services. This issue is due to a failure in the application to properly sanitize user-supplied input. Attackers may exploit this issue via a web client. An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks. A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

Hackers Center Security Group (http://www.hackerscenter.com) Credit: Doz

Risk: Medium Class: Input Validation Error Remote: YES Local: N/A

Vendor: eGov Strategies LLC Product: Content Management System

http://www.egovstrategies.com/

Vulrnable Files:

center.exe Index.exe

Attackers can exploit these issues via a web client.

Exploit URLs:

  • Classified *

Due to the nature of advisorie, many Government Sites are running this application. Only if your site is vulrnable we wil disclose the detaisl to site admin.

Google Search: (Index.exe)

http://www.google.com/search?hl=en&q=ext%3Aexe+inurl%3A%28Services%29&btnG=Search

Google Search: (Center.exe)

http://www.google.com/search?hl=en&q=ext%3Aexe+inurl%3A%28center%29&btnG=Search

Only becoming a Ethical Hacker, you can stop a Hacker. Learn with out having to pay thousands!- http://kit.hackerscenter.com - The most comprehensive security pack you will ever find on the net!