Freeside XSS vuln.

2007-09-25T00:00:00
ID SECURITYVULNS:DOC:18061
Type securityvulns
Reporter Securityvulns
Modified 2007-09-25T00:00:00

Description

Freeside XSS vuln.

Vuln. discovered by : r0t Date: 25 September 2007 vendor:www.sisd.com affected versions:Freeside v1.7.2 other versions also can be affected. orginal advisory: http://pridels-team.blogspot.com/2007/09/freeside-xss-vuln.html

Freeside contains a flaw that allows a remote Cross-Site Scripting attacks.Input passed to the "failed" parameter in "search/cust_bill_event.cgi" isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

Solution: Edit the source code to ensure that input is properly sanitised.