Vulnerability in theme WordPress Classic 1.5

2007-08-13T00:00:00
ID SECURITYVULNS:DOC:17751
Type securityvulns
Reporter Securityvulns
Modified 2007-08-13T00:00:00

Description

Здравствуйте 3APA3A!

Сообщаю вам о найденной мною Cross-Site Scripting уязвимости в теме WordPress Classic 1.5.

XSS:

http://site/index.php/%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

Уязвимость связана с недостаточной фильтрацией переменной PHP_SELF. Подобная уязвимость ранее уже была найдена в коде самого WordPress.

Дополнительная информация о данной уязвимости у меня на сайте: http://websecurity.com.ua/1234/

В версии WordPress 2.1.3 и последующих данная уязвимость в Classic теме уже исправлена.

Best wishes & regards, MustLive Администратор сайта http://websecurity.com.ua