phpMyAdmin multiple XSS vuln.

2007-08-10T00:00:00
ID SECURITYVULNS:DOC:17731
Type securityvulns
Reporter Securityvulns
Modified 2007-08-10T00:00:00

Description

phpMyAdmin multiple XSS vuln.

Vuln. discovered by : r0t Date: 10 August 2007 vendor:http://www.phpmyadmin.net/ orginal advisory: http://pridels-team.blogspot.com/2007/08/phpmyadmin-multiple-xss-vuln.html affected versions:2.10.3 (latest stable version) prior versions also can be affected.

phpMyAdmin contains multiple flaws that allows a remote Cross-Site Scripting attacks.Input passed to the "unlim_num_rows","sql_query","pos" parameter in "tbl_export.php" and "session_max_rows","pos" parameter in "sql.php" and "username" parameter in "server_privileges.php" and "sql_query" parameter in "main.php" isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

Solution: Edit the source code to ensure that input is properly sanitised.