[Full-disclosure] *****SPAM***** New Wordpress 2.2.1 Vulnerabilities and the First Weblog XSS Worm

2007-08-01T00:00:00
ID SECURITYVULNS:DOC:17664
Type securityvulns
Reporter Securityvulns
Modified 2007-08-01T00:00:00

Description

Hey Guys, this another one of my FD Releases!

I found several critical Wordpress 2.2.1 Vulnerabilities, in detail explained here:

http://mybeni.rootzilla.de/mybeNi/2007/wordpress_zeroday_vulnerability_roundhouse_kick_and_why_i_nearly_wrote_the_first_blog_worm/

Plus I made - by using the Exploits I created during my research - the first weblog worm, but a "friendly" one: It guides people coming from their /wp-admin/ Wordpress Control Panel through the Patching process of 3 critical Security Vulnerabilities (XSS, Pers. XSS, SQLInjection), all based on Javascript and by using the Vulnerabilities. All you need is to post a comment with a link to my blog http://mybeni.rootzilla.de/mybeNi/ to your own one and then, all you have to do is to click on the link e.g. in the comment Moderation area. My Server sees that you're Referring from an Admin Panel and the Worm Thingy will show up. Pictures and more are provided here: http://mybeni.rootzilla.de/mybeNi/2007/this_is_the_first_weblog_xss_worm/

cheers,

Benjamin Flesch mybeNi websecurity the 17yo who hacked google.


Full-Disclosure - We believe in it. Charter: http://lists.grok.org.uk/full-disclosure-charter.html Hosted and sponsored by Secunia - http://secunia.com/