Sporum Forum XSS vuln.

2007-06-12T00:00:00
ID SECURITYVULNS:DOC:17236
Type securityvulns
Reporter Securityvulns
Modified 2007-06-12T00:00:00

Description

Sporum Forum XSS vuln.

Vuln. discovered by : r0t Date: 12 June 2007 vendor:http://sporum.js-x.com/ affected versions: 3.0.9 and prior orginal advisory: http://pridels-team.blogspot.com/2007/06/sporum-forum-xss-vuln.html

Sporum Forum contains a flaw that allows a remote Cross-Site Scripting attacks.Input passed to the "view" and "mode" parameter in "comments.cgi" isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

Solution: Edit the source code to ensure that input is properly sanitised.