[DRUPAL-SA-2007-005] Drupal 4.7.6 / 5.1 fixes arbitrary code execution issue

Type securityvulns
Reporter Securityvulns
Modified 2007-01-30T00:00:00


Drupal security advisory DRUPAL-SA-2007-005

Project: Drupal core Version: 4.7.x, 5.x Date: 2007-Jan-29 Security risk: Highy critical Exploitable from: Remote Vulnerability: Arbitrary code execution


Previews on comments were not passed through normal form validation routines, enabling users with the 'post comments' permission and access to more than one input filter to execute arbitrary code. By default, anonymous and authenticated users have access to only one input format.

Immediate workarounds include: disabling the comment module, revoking the 'post comments' permission for all users or limiting access to one input format.

Versions affected

  • Drupal 4.7.x versions before Drupal 4.7.6
  • Drupal 5.x versions before Drupal 5.1


  • If you are running Drupal 4.7.x then upgrade to Drupal 4.7.6. http://ftp.osuosl.org/pub/drupal/files/projects/drupal-4.7.6.tar.gz
  • If you are running Drupal 5.x then upgrade to Drupal 5.1. http://ftp.osuosl.org/pub/drupal/files/projects/drupal-5.1.tar.gz

  • To patch Drupal 4.7.5 use http://drupal.org/files/sa-2007-005/SA-2007-005-4.7.5.patch.

  • To patch Drupal 5.0 use http://drupal.org/files/sa-2007-005/SA-2007-005-5.0.patch.

Please note that the patches only contain changes related to this advisory, and do not fix bugs that were solved in 4.7.6 or 5.1.

Reported by

The Drupal security team.


The security contact for Drupal can be reached at security at drupal.org or using the form at http://drupal.org/contact.

// Uwe Hermann, on behalf of the Drupal Security Team.

http://www.hermann-uwe.de | http://www.holsham-traders.de http://www.crazy-hacks.org | http://www.unmaintained-free-software.org