[SA23908] Drupal Project Module Script Insertion Vulnerability

2007-01-25T00:00:00
ID SECURITYVULNS:DOC:15866
Type securityvulns
Reporter Securityvulns
Modified 2007-01-25T00:00:00

Description

TITLE: Drupal Project Module Script Insertion Vulnerability

SECUNIA ADVISORY ID: SA23908

VERIFY ADVISORY: http://secunia.com/advisories/23908/

CRITICAL: Less critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: Drupal Project Module 4.x http://secunia.com/product/12912/

DESCRIPTION: A vulnerability has been reported in the Project module for Drupal, which can be exploited by malicious users to conduct script insertion attacks.

Input passed to unspecified parameters is not properly sanitised before being stored. This can be exploited to insert arbitrary HTML and script code, which is executed in a user's browser session in context of an affected site when the offending data is viewed.

Successful exploitation requires valid user credentials, that the user has the "Maintain projects" permission, and that the user is able to create project nodes.

The vulnerability is reported in version 4.7.x-2.1, 4.7.x-1.1, 4.6.x-1.1, 4.7.0 (from before the new release system) and 4.6.0 (from before the new release system).

SOLUTION: Update to version 4.7.x-2.2 or 4.7.x-1.2.

PROVIDED AND/OR DISCOVERED BY: The vendor credits Brandon Bergren a.k.a bdragon.

ORIGINAL ADVISORY: DRUPAL-SA-2007-004: http://drupal.org/node/112146


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.