[SA22690] Yazd Discussion Forum Two Security Bypass Issues

2006-11-03T00:00:00
ID SECURITYVULNS:DOC:14916
Type securityvulns
Reporter Securityvulns
Modified 2006-11-03T00:00:00

Description

TITLE: Yazd Discussion Forum Two Security Bypass Issues

SECUNIA ADVISORY ID: SA22690

VERIFY ADVISORY: http://secunia.com/advisories/22690/

CRITICAL: Less critical

IMPACT: Security Bypass, Exposure of sensitive information

WHERE: >From remote

SOFTWARE: Yazd Discussion Forum Software 1.x http://secunia.com/product/12482/ Yazd Discussion Forum Software 2.x http://secunia.com/product/12483/

DESCRIPTION: Two security issues have been reported in Yazd Discussion Forum Software, which potentially can be exploited by malicious users to gain sensitive information and bypass security functionality.

1) Users with the permission to create messages in one forum could reply to messages in all forums.

2) An unspecified error in assembling permissions caused users to get more permissions for the forums than intended.

The security issues are reported in all versions prior to 3.0.

SOLUTION: The vendor has corrected both issues in version 3.0 (beta).

PROVIDED AND/OR DISCOVERED BY: Reported by the vendor.

ORIGINAL ADVISORY: http://sourceforge.net/project/shownotes.php?release_id=460547


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.