[SA22014] PHP-Post Multiple Vulnerabilities

2006-09-20T00:00:00
ID SECURITYVULNS:DOC:14360
Type securityvulns
Reporter Securityvulns
Modified 2006-09-20T00:00:00

Description

TITLE: PHP-Post Multiple Vulnerabilities

SECUNIA ADVISORY ID: SA22014

VERIFY ADVISORY: http://secunia.com/advisories/22014/

CRITICAL: Moderately critical

IMPACT: Cross Site Scripting, Manipulation of data, Exposure of sensitive information

WHERE: >From remote

SOFTWARE: PHP-Post 1.x http://secunia.com/product/6191/

DESCRIPTION: HACKERS PAL has reported some vulnerabilities in PHP-Post, which can be exploited by malicious people to disclose sensitive information, and conduct cross-site scripting and SQL injection attacks.

1) Input passed to the "template" parameter in footer.php is not properly verified before being used to include files. This can be exploited to include arbitrary files from local resources.

Successful exploitation requires that "register_globals" is enabled and "magic_quotes_gpc" is disabled.

2) Input passed to parameters in multiple files is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

Examples: http://[host]/template.php?txt_error=[code] http://[host]/template.php?txt_templatenotexist=[code] http://[host]/dropdown.php?txt_jumpto=[code] http://[host]/loginline.php?txt_login=[code]

Note: Reportedly more files are affected.

3) Input passed to the "user" parameter in profile.php and to the "table_prefix" parameter in multiple files is not properly sanitised before being used in SQL queries. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

Examples: http://[host]/index.php?table_prefix=[code] http://[host]/profile.php?table_prefix=[code] http://[host]/header.php?msgid=w&table_prefix=[code]

Successful exploitation of the "user" parameter requires that "magic_quotes_gpc" is disabled.

The vulnerabilities have been reported in version 1.01. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly sanitised and verified.

PROVIDED AND/OR DISCOVERED BY: HACKERS PAL


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.