[SA21866] ColdFusion Denial of Service and Sandbox Bypass

2006-09-13T00:00:00
ID SECURITYVULNS:DOC:14257
Type securityvulns
Reporter Securityvulns
Modified 2006-09-13T00:00:00

Description

TITLE: ColdFusion Denial of Service and Sandbox Bypass

SECUNIA ADVISORY ID: SA21866

VERIFY ADVISORY: http://secunia.com/advisories/21866/

CRITICAL: Moderately critical

IMPACT: Security Bypass, DoS

WHERE: >From remote

SOFTWARE: Macromedia ColdFusion MX 7 http://secunia.com/product/4984/

DESCRIPTION: Two vulnerabilities have been reported in ColdFusion, which can be exploited by malicious, local users to bypass certain security restrictions and by malicious people to cause a DoS (Denial of Service).

1) It is possible to cause an infinite loop in ColdFusion by sending a specially crafted command to the ColdFusion Flash Remoting Gateway.

2) An error exists due to CFML templates outside a sandbox being able to call ColdFusion components within a sandbox in certain situations.

The vulnerabilities have been reported in versions 7 and 7.0.1.

SOLUTION: Update to version 7.0.2 or apply hotfixes for version 7.0.1: http://www.adobe.com/support/security/bulletins/hf701-apsb06-12.zip http://www.adobe.com/support/coldfusion/ts/documents/94491491/hf701-61892.zip

PROVIDED AND/OR DISCOVERED BY: The vendor credits: 1) Shigeyoshi Muraoka, IT Frontier Corporation 2) Stephen Moretti, Nil Desperandum

ORIGINAL ADVISORY: Adobe Systems: http://www.adobe.com/support/security/bulletins/apsb06-12.html http://www.adobe.com/support/security/bulletins/apsb06-13.html


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.