[KAPDA::#55] - Joomla poll component vulnerability

2006-08-21T00:00:00
ID SECURITYVULNS:DOC:13959
Type securityvulns
Reporter Securityvulns
Modified 2006-08-21T00:00:00

Description

KAPDA New advisory

Vendor: http://www.joomla.org Vulnerable: 1.0.10 (prior versions also maybe Affected) Bug: user session validation weakness Exploitation: Remote with browser Poc: available

Description:

>From vendora€™s website. Joomla! is an award-winning Content Management System (CMS) that will help you build websites and other powerful online applications. Best of all, Joomla! is an open source solution that is freely available to everybody.

Vulnerability:

There is a logical weakness in the codes of poll component ( pollAddVote Function )and initSession(); that may allow remote users to vote an option repeatedly in a short time without any restriction. Even ita€™s possible to vote an unpublished poll Item.

Original advisory and Poc:

http://www.kapda.ir/advisory-407.html

Solution:

Vendor was informed via official Bug Report on the official 1.0.x Bug Tracker But there is no vendor supplied patch at this time.

Credit :

Discovered & released by trueend5 (trueend5 kapda ir) Security Science Researchers Institute Of Iran [http://www.KAPDA.ir]


Do You Yahoo!? Tired of spam? Yahoo! Mail has the best spam protection around http://mail.yahoo.com