[SA19845] wodSSHServer Key Exchange Algorithm String Buffer Overflow

2006-05-14T00:00:00
ID SECURITYVULNS:DOC:12671
Type securityvulns
Reporter Securityvulns
Modified 2006-05-14T00:00:00

Description

TITLE: wodSSHServer Key Exchange Algorithm String Buffer Overflow

SECUNIA ADVISORY ID: SA19845

VERIFY ADVISORY: http://secunia.com/advisories/19845/

CRITICAL: Highly critical

IMPACT: System access

WHERE: >From remote

SOFTWARE: wodSSHServer ActiveX Component 1.x http://secunia.com/product/9609/

DESCRIPTION: Gerry Eisenhaur has discovered a vulnerability in WeOnlyDo wodSSHServer, which can be exploited by malicious people to cause a DoS (Denial of Service) and potentially compromise a vulnerable system.

The vulnerability is caused due to a boundary error within the handling of the key exchange algorithm string sent by an SSH client. This can be exploited to cause a stack-based buffer overflow and may allow arbitrary code execution.

The vulnerability has been confirmed in versions 1.2.7 and 1.3.3 DEMO. Other versions may also be affected.

SOLUTION: Restrict access to trusted IP addresses only.

PROVIDED AND/OR DISCOVERED BY: Gerry Eisenhaur


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.