[SA18828] SSH Tectia Server SFTP Service Unspecified Vulnerability

2006-02-16T00:00:00
ID SECURITYVULNS:DOC:11481
Type securityvulns
Reporter Securityvulns
Modified 2006-02-16T00:00:00

Description

TITLE: SSH Tectia Server SFTP Service Unspecified Vulnerability

SECUNIA ADVISORY ID: SA18828

VERIFY ADVISORY: http://secunia.com/advisories/18828/

CRITICAL: Moderately critical

IMPACT: System access

WHERE: >From remote

SOFTWARE: SSH Secure Shell for Servers 3.x http://secunia.com/product/808/ SSH Secure Shell for Windows Servers 3.x http://secunia.com/product/5316/ SSH Tectia Server 4.x http://secunia.com/product/3233/

DESCRIPTION: A vulnerability has been reported in SSH Tectia Server, which potentially can be exploited by malicious users to compromise a vulnerable system.

The vulnerability is caused due to an unspecified error in the SFTP component during logging of accessed file names. This can e.g. be exploited by restricted users to execute arbitrary commands or by one user to execute arbitrary commands as another user if that user is tricked into accessing a malicious file.

Successful exploitation requires that a user is authenticated to the SFTP service.

The vulnerability affects the following products: * SSH Tectia Server 4.4.0 (A and T) * SSH Tectia Server 4.3.6 (A and T) and prior. * SSH Secure Shell Server 3.2.9 and prior.

SOLUTION: Update to SSH Tectia Server 4.3.7 or 4.4.2. http://www.ssh.com/support/downloads/tectia-server

Disable the SFTP service.

PROVIDED AND/OR DISCOVERED BY: Reported by vendor.


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.