[SA18302] NKads Login SQL Injection Vulnerability

2006-01-05T00:00:00
ID SECURITYVULNS:DOC:10904
Type securityvulns
Reporter Securityvulns
Modified 2006-01-05T00:00:00

Description

TITLE: NKads Login SQL Injection Vulnerability

SECUNIA ADVISORY ID: SA18302

VERIFY ADVISORY: http://secunia.com/advisories/18302/

CRITICAL: Highly critical

IMPACT: Security Bypass, Manipulation of data, System access

WHERE: >From remote

SOFTWARE: NKads 1.x http://secunia.com/product/6738/

DESCRIPTION: SoulBlack Security Research has discovered a vulnerability in NKads, which can be exploited by malicious people to conduct SQL injection attacks and compromise a vulnerable system.

Input passed to the "usuario_nkads_admin" and "password_nkads_admin" parameters when logging into the administration section isn't properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

Successful exploitation requires that "magic_quotes_gpc" is disabled.

This can further be exploited to bypass the authentication process and access the administration section where arbitrary PHP scripts can be uploaded to a location inside the web root (e.g. using the filename "name.jpg.php").

The vulnerability has been confirmed in version 1.0 Alfa3 (stable). Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly sanitised.

PROVIDED AND/OR DISCOVERED BY: SoulBlack Security Research

ORIGINAL ADVISORY: http://www.soulblack.com.ar/repo/papers/advisory/nkads_advisory.txt


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.