Lucene search
+L

3014 matches found

Positive Technologies
Positive Technologies
•added 2026/06/29 12:00 a.m.•26 views

PT-2026-53574

MiniZip in zlib through 1.3 has an integer overflow and resultant heap-based buffer overflow in zipOpenNewFileInZip4 64 via a long filename, comment, or extra field. NOTE: MiniZip is not a supported part of the zlib product. pyminizip uses version 1.2.11 of zlib's code...

9.8CVSS7.4AI score0.03179EPSS
SaveExploits0References18
Positive Technologies
Positive Technologies
•added 2026/06/28 12:00 a.m.•29 views

PT-2026-64414

Name of the Vulnerable Software and Affected Versions FFmpeg versions prior to 8.1.2 Description An information disclosure issue exists in the LCL/ZLIB video decoder. An attacker can expose uninitialized heap memory by providing a valid zlib stream that inflates to fewer bytes than the expected...

8.8CVSS7.5AI score0.00851EPSS
SaveExploits0References113
Fedora
Fedora
•added 2026/06/26 12:59 a.m.•21 views

[SECURITY] Fedora 44 Update: perl-IO-Compress-2.221-1.fc44

This distribution provides a Perl interface to allow reading and writing of compressed data created with the zlib and bzip2 libraries. IO-Compress supports reading and writing of bzip2, RFC 1950, RFC 1951, RFC 1952 i.e. gzip and zip files/buffers. The following modules used to be distributed...

7.8CVSS7.2AI score0.00609EPSS
SaveExploits3
AstraLinux
AstraLinux
•added 2026/06/24 3:11 p.m.•11 views

Astra Linux – Vulnerability in zlib

Zlib before version 1.3.2 allowed CPU consumption through crc32combine64 and crc32combinegen64, because x2nmodp could perform right shifts within a loop without a termination condition...

5.5CVSS6.7AI score0.00187EPSS
SaveExploits1References3
AstraLinux
AstraLinux
•added 2026/06/24 3:11 p.m.•14 views

Astra Linux – Vulnerability in Ruby 3.1

Zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0, and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstreambufferungets function prepends bytes provided by the caller before previously produced...

9.8CVSS8AI score0.00752EPSS
SaveExploits0References3
OSV
OSV
•added 2026/06/19 10:13 a.m.•9 views

OPENSUSE-SU-2026:21142-1 Security update for perl-Compress-Raw-Zlib

This update for perl-Compress-Raw-Zlib fixes the following issues: Changes in perl-Compress-Raw-Zlib: - updated to 2.222 see /usr/share/doc/packages/perl-Compress-Raw-Zlib/Changes 2.222 27 February 2026 Add SECURITY.md. Fixes 40 Fix spelling typos 2.221 27 February 2026 Merge remote-tracking bran...

9.8CVSS7.2AI score0.00793EPSS
SaveExploits0References1
IBM Security Bulletins
IBM Security Bulletins
•added 2026/06/19 7:52 a.m.•20 views

Security Bulletin: Due to the use of zlib, IBM EntireX is vulnerable to Improper Validation of Specified Quantity in Input vulnerabilities (CVE-2026-3381, CVE-2026-27171).

Summary Due to the use of zlib, IBM EntireX is vulnerable to Improper Validation of Specified Quantity in Input vulnerabilities CVE-2026-3381, CVE-2026-27171. The version of zlib has been updated within IBM EntireX in order to address the vulnerabilities. Vulnerability Details CVEID:CVE-2026-3381...

9.8CVSS6.4AI score0.00793EPSS
SaveExploits1Affected Software1
Fedora
Fedora
•added 2026/06/19 1:10 a.m.•23 views

[SECURITY] Fedora 43 Update: perl-Archive-Tar-3.04-522.fc43

Archive::Tar provides an object oriented mechanism for handling tar files. It provides class methods for quick and easy files handling while also allowing for the creation of tar file objects for custom manipulation. If you have the IO::Zlib module installed, Archive::Tar will also support...

9.1CVSS7.2AI score0.0043EPSS
SaveExploits0
GithubExploit
GithubExploit
•added 2026/06/14 3:17 p.m.•151 views

Exploit for Improper Handling of Length Parameter Inconsistency in Mongodb

CVE-2025-14847-mongobleed CVE-2025-14847 mongobleed python fil...

8.7CVSS7.8AI score0.83218EPSS
SaveExploits39
Tenable Nessus
Tenable Nessus
•added 2026/06/13 12:00 a.m.•14 views

Photon OS 5.0: Zlib PHSA-2026-5.0-0874

An update of the zlib package has been released. %NASLMINLEVEL 80900 C Tenable, Inc. The descriptive text and package checks in this plugin were extracted from VMware Security Advisory PHSA-2026-5.0-0874. The text itself is copyright C VMware, Inc. include'compat.inc'; if description...

5.5CVSS6.2AI score0.00187EPSS
SaveExploits1References2
Photon
Photon
•added 2026/06/11 12:00 a.m.•28 views

Critical Photon OS Security Update - PHSA-2026-5.0-91-0874

Updates of 'linux-esx', 'libxml2', 'zlib', 'libxslt', 'openssl', 'linux' packages of Photon OS have been released...

9.1CVSS6.2AI score0.04002EPSS
SaveExploits3
Tenable Nessus
Tenable Nessus
•added 2026/06/09 12:00 a.m.•14 views

EulerOS 2.0 SP11 : zlib (EulerOS-SA-2026-2270)

According to the versions of the zlib packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop that has no...

5.5CVSS6.4AI score0.00187EPSS
SaveExploits1References2
Tenable Nessus
Tenable Nessus
•added 2026/06/09 12:00 a.m.•19 views

EulerOS 2.0 SP11 : zlib (EulerOS-SA-2026-2233)

According to the versions of the zlib packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop that has no...

5.5CVSS6.4AI score0.00187EPSS
SaveExploits1References2
Tenable Nessus
Tenable Nessus
•added 2026/06/08 12:00 a.m.•37 views

Amazon Linux 2023 : ruby3.4, ruby3.4-bundled-gems, ruby3.4-default-gems (ALAS2023-2026-1807)

It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2026-1807 advisory. zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader...

9.8CVSS8AI score0.01253EPSS
SaveExploits0References14
BDU FSTEC
BDU FSTEC
•added 2026/06/08 12:00 a.m.•13 views

The vulnerability of the Perl module from the zlib library allows attackers to compromise the confidentiality, integrity, and accessibility of the protected information.

The vulnerability of the Perl module from the zlib library is related to incorrect input of configuration data. Exploiting this vulnerability allows an attacker to compromise the confidentiality, integrity, and accessibility of the protected information...

10CVSS7.7AI score0.00793EPSS
SaveExploits0References13Affected Software2
Amazon
Amazon
•added 2026/06/08 12:00 a.m.•23 views

Important: ruby3.4

Issue Overview: zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstreambufferungets function prepends caller-provided bytes ahead of previously...

9.8CVSS7.9AI score0.01253EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2026/06/06 12:00 a.m.•28 views

EulerOS Virtualization 2.13.1 : zlib (EulerOS-SA-2026-2155)

According to the versions of the zlib package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop th...

5.5CVSS6.3AI score0.00187EPSS
SaveExploits1References2
Tenable Nessus
Tenable Nessus
•added 2026/06/06 12:00 a.m.•17 views

EulerOS Virtualization 2.12.1 : zlib (EulerOS-SA-2026-2092)

According to the versions of the zlib package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop th...

5.5CVSS6.3AI score0.00187EPSS
SaveExploits1References2
Tenable Nessus
Tenable Nessus
•added 2026/06/06 12:00 a.m.•17 views

EulerOS Virtualization 2.12.0 : zlib (EulerOS-SA-2026-2117)

According to the versions of the zlib package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop th...

5.5CVSS6.3AI score0.00187EPSS
SaveExploits1References2
Tenable Nessus
Tenable Nessus
•added 2026/06/06 12:00 a.m.•20 views

EulerOS Virtualization 2.13.0 : zlib (EulerOS-SA-2026-2194)

According to the versions of the zlib package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : zlib before 1.3.2 allows CPU consumption via crc32combine64 and crc32combinegen64 because x2nmodp can do right shifts within a loop th...

5.5CVSS6.3AI score0.00187EPSS
SaveExploits1References2
Rows per page
Query Builder