62932 matches found
PT-2026-103096
Name of the Vulnerable Software and Affected Versions Moodle affected versions not specified Description The XML grade import feature lacks proper Cross-Site Request Forgery CSRF token validation. CSRF is a flaw that allows an attacker to trick an authenticated user into performing actions they d...
CVE-2026-102588: Origin Validation Error
A flaw was found in Moodle. The XML grade import feature lacks proper Cross-Site Request Forgery CSRF token validation. By tricking an authenticated user with grade management permissions into visiting a malicious webpage, an attacker can trigger unauthorized requests on the victim's behalf. This...
PT-2026-103133
Name of the Vulnerable Software and Affected Versions WSS4J versions prior to 4.0.2 WSS4J versions prior to 3.0.6 WSS4J versions prior to 2.4.4 Description In the streaming StAX code, a signature reference using the WS-Security STR-Transform causes an internal flag indicating content is signed to...
Rocky Linux 9.6 [TuxCare] Security Update: perl-XML-Parser (ALMALINUX9.6:CLSA-2026:1777396174)
The Rocky Linux 9.6 host has a package installed that is affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1777396174 advisory. - XML::Parser versions through 2.47 for Perl has an off-by-one heap buffer overflow in stserialstack. In the case stackptr == stacksize - 1...
AlmaLinux 9.2 [TuxCare] Security Update: libxml2 / libxml2-devel / libxml2-static / python3-libxml2 (ALMALINUX9.2:CLSA-2026:1789473529)
The AlmaLinux 9.2 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1789473529 advisory. - Use After Free in libxml2's xmlParseInternalSubset from GNOME libxml2 version 2.9.11 to 2.11.0 allows a remote attacker to cause a...
Rocky Linux 9.6 [TuxCare] Security Update: libvirt / libvirt-client / libvirt-client-qemu / libvirt-daemon / etc (ALMALINUX9.6:CLSA-2026:1779871378)
The Rocky Linux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1779871378 advisory. - A flaw was discovered in libvirt in the XML file processing. More specifically, the parsing of user provided XML files was performed befo...
Rocky Linux 9.6 [TuxCare] Security Update: log4j / log4j-jcl / log4j-slf4j / log4j-web (ALMALINUX9.6:CLSA-2026:1779124827)
The Rocky Linux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1779124827 advisory. - The Log4j1XmlLayout from the Apache Log4j 1-to-Log4j 2 bridge fails to escape characters forbidden by the XML 1.0 standard, producing...
AlmaLinux 9.6 [TuxCare] Security Update: perl-XML-Parser (ALMALINUX9.6:CLSA-2026:1777396174)
The AlmaLinux 9.6 host has a package installed that is affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1777396174 advisory. - XML::Parser versions through 2.47 for Perl has an off-by-one heap buffer overflow in stserialstack. In the case stackptr == stacksize - 1,...
Telerik UI for ASP.NET AJAX 2009.1.314 < 2026.2.708 LayoutBuilder XXE DoS
The version of Progress Telerik UI for ASP.NET AJAX installed on the remote Windows host is 2009.1.314 or later and prior to 2026.2.708. It is, therefore, affected by a denial of service vulnerability. The internal LayoutBuilder control processes client-state XML without disabling DTD processing,...
CentOS Linux 8 [TuxCare] Security Update: libxml2 / libxml2-devel / libxml2-static / python3-libxml2 Multiple Vulnerabilities (CENTOS-STREAM8:CLSA-2025:1742466508)
The CentOS Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare CENTOS-STREAM8:CLSA-2025:1742466508 advisory. - libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a use-after-free in xmlSchemaIDCFillNodeTables and...
AlmaLinux 9.6 [TuxCare] Security Update: libxslt / libxslt-devel (ALMALINUX9.6:CLSA-2025:1765288229)
The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2025:1765288229 advisory. - A flaw was found in the libxslt library. The same memory field, psvi, is used for both stylesheet and input data, which can lead to type...
AlmaLinux 9.6 [TuxCare] Security Update: libvirt / libvirt-client / libvirt-client-qemu / libvirt-daemon / etc (ALMALINUX9.6:CLSA-2026:1779871378)
The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1779871378 advisory. - A flaw was discovered in libvirt in the XML file processing. More specifically, the parsing of user provided XML files was performed before...
AlmaLinux 9.6 [TuxCare] Security Update: log4j / log4j-jcl / log4j-slf4j / log4j-web (ALMALINUX9.6:CLSA-2026:1779124827)
The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1779124827 advisory. - The Log4j1XmlLayout from the Apache Log4j 1-to-Log4j 2 bridge fails to escape characters forbidden by the XML 1.0 standard, producing...
ALSA-2026:74001 Important: expat security update
Expat is a C library for parsing XML documents. Security Fixes: expat: Expat: Denial of Service via quadratic complexity in attribute processing CVE-2026-66046 expat: Expat: XML Injection via Malformed UTF-16 Input CVE-2026-93990 For more details about the security issues, including the impact, a...
RHEL 10 : expat (RHSA-2026:74001)
The remote Redhat Enterprise Linux 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2026:74001 advisory. Expat is a C library for parsing XML documents. Security Fixes: expat: Expat: Denial of Service via quadratic complexity in attribute...
MiracleLinux 9 : expat-2.5.0-6.el9_8.5 (AXSA:2026-1939:13)
The remote MiracleLinux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the AXSA:2026-1939:13 advisory. expat: Expat: Denial of Service via quadratic complexity in attribute processing CVE-2026-66046 expat: Expat: XML Injection via Malformed UTF-16 Inp...
RockyLinux 9 : expat (RLSA-2026:72663)
The remote RockyLinux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2026:72663 advisory. expat: Expat: Denial of Service via quadratic complexity in attribute processing CVE-2026-66046 expat: Expat: XML Injection via Malformed UTF-16 Input...
Rocky Linux 9.6 [TuxCare] Security Update: expat / expat-devel / expat-static Multiple Vulnerabilities (ALMALINUX9.6:CLSA-2026:1790177624)
The Rocky Linux 9.6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1790177624 advisory. - Expat through 2.8.3 contains an out-of-bounds read vulnerability that allows attackers to trigger memory corruption by processin...
AlmaLinux 9.2 [TuxCare] Security Update: perl-XML-Parser (ALMALINUX9.2:CLSA-2026:1776940444)
The AlmaLinux 9.2 host has a package installed that is affected by a vulnerability as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1776940444 advisory. - XML::Parser versions through 2.47 for Perl has an off-by-one heap buffer overflow in stserialstack. In the case stackptr == stacksize - 1,...
CentOS Linux 6 [TuxCare] Security Update: python / python-devel / python-libs / python-test / python-tools / etc (CENTOS6:CLSA-2026:1781346632)
The CentOS Linux 6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare CENTOS6:CLSA-2026:1781346632 advisory. - xml.parsers.expat and xml.etree.ElementTree use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to...