2222 matches found
sticky_keys_hunter
Sticky Keys Hunter This POC bash script tests for sticky keys and utilman backdoors. The script will connect to an RDP server, send both the sticky keys and utilman triggers and screenshot the result. This script was written to prove a theory I had about detecting these backdoors in a blackbox...
Important: Red Hat Security Advisory: libX11 security update
An update for libX11 is now available for Red Hat Enterprise Linux 8. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from th...
ALSA-2026:89730 Important: libX11 security update
The libX11 packages contain the core X11 protocol client library. Security Fixes: libX11: libX11: Heap-based buffer overflow via malicious X server CVE-2026-88806 For more details about the security issues, including the impact, a CVSS score, acknowledgments, and other related information, refer ...
Important: libX11 security update
The libX11 packages contain the core X11 protocol client library. Security Fixes: libX11: libX11: Heap-based buffer overflow via malicious X server CVE-2026-88806 For more details about the security issues, including the impact, a CVSS score, acknowledgments, and other related information, refer ...
Important: libXtst
Issue Overview: An out-of-bounds read in libXtst's RECORD reply parser in libXtst before 1.2.6 could be used by malicious X servers to crash attached X clients. CVE-2026-94286 Affected Packages: libXtst Issue Correction: Run dnf update libXtst --releasever 2023.12.20261026 or dnf update --advisor...
Important: libXtst
Issue Overview: An out-of-bounds read in libXtst's RECORD reply parser in libXtst before 1.2.6 could be used by malicious X servers to crash attached X clients. CVE-2026-94286 Affected Packages: libXtst Note: This advisory is applicable to Amazon Linux 2 AL2 Core repository. Visit this FAQ sectio...
Amazon Linux 2 : libXtst (ALAS-2026-4012)
The version of libXtst installed on the remote host is prior to 1.2.3-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2026-4012 advisory. An out-of-bounds read in libXtst's RECORD reply parser in libXtst before 1.2.6 could be used by malicious X servers to crash attach...
Unity Linux 20.1050e / 20.1060e / 20.1070e Security Update: libXi (UTSA-2026-142334)
The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2026-142334 advisory. An out-of-bounds read in libXi's XI2 XIQueryDevice reply parsing in libXi before 1.8.4 can be used by a malicious X server to crash an attached X client. Tenable has...
Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 22.04 LTS / 24.04 LTS / 26.04 LTS / 26.10 : libXtst vulnerabilities (USN-8939-1)
The remote Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 22.04 LTS / 24.04 LTS / 26.04 LTS / 26.10 host has a package installed that is affected by multiple vulnerabilities as referenced in the USN-8939-1 advisory. It was discovered that libXtst did not properly handle certain RECORD replies from th...
USN-8939-1 libxtst vulnerabilities
It was discovered that libXtst did not properly handle certain RECORD replies from the X server. A malicious X server could possibly use this issue to cause libXtst clients to crash, resulting in a denial of service. CVE-2026-94286 Tobias Stoeckmann discovered that libXtst did not properly handle...
USN-8939-1: libXtst vulnerabilities
It was discovered that libXtst did not properly handle certain RECORD replies from the X server. A malicious X server could possibly use this issue to cause libXtst clients to crash, resulting in a denial of service. CVE-2026-94286 Tobias Stoeckmann discovered that libXtst did not properly handle...
OESA-2026-4291 libXi security update
libXi is the client-side library for the X Input Extension. Security Fixes: An out-of-bounds read in libXi's XQueryDeviceState in libXi before 1.8.4 could be used by aCVE-2026-93541 An out-of-bounds read in libXi's XI2 class parsing via sizeclasses and copyclasses in libXi before 1.8.4 could be...
OESA-2026-4290 libXi security update
libXi is the client-side library for the X Input Extension. Security Fixes: An out-of-bounds read in libXi's XQueryDeviceState in libXi before 1.8.4 could be used by aCVE-2026-93541 An out-of-bounds read in libXi's XI2 class parsing via sizeclasses and copyclasses in libXi before 1.8.4 could be...
OESA-2026-4289 libXi security update
libXi is the client-side library for the X Input Extension. Security Fixes: An out-of-bounds read in libXi's XQueryDeviceState in libXi before 1.8.4 could be used by aCVE-2026-93541 An out-of-bounds read in libXi's XI2 class parsing via sizeclasses and copyclasses in libXi before 1.8.4 could be...
OESA-2026-4288 libXi security update
libXi is the client-side library for the X Input Extension. Security Fixes: An out-of-bounds read in libXi's XQueryDeviceState in libXi before 1.8.4 could be used by aCVE-2026-93541 An out-of-bounds read in libXi's XI2 class parsing via sizeclasses and copyclasses in libXi before 1.8.4 could be...
Astra Linux – Vulnerability in xwayland, xorg-server
A flaw was discovered in the X.Org X server. This vulnerability, an out-of-bounds read, affects the handling of XKB X Keyboard Extension modifier maps. An attacker with access to the X11 server can exploit this by sending a malformed request, causing the server to read beyond its intended memory...
Important: libX11
Issue Overview: A malicious X server could exploit a buffer overflow in libX11 before 1.8.14 during handling of XkbGetMap overflowing the keysymmap. CVE-2026-88806 Affected Packages: libX11 Note: This advisory is applicable to Amazon Linux 2 AL2 Core repository. Visit this FAQ section for the...
EulerOS 2.0 SP13 : libXfont2 (EulerOS-SA-2026-4058)
According to the versions of the libXfont2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A heap buffer overflow due to missing size checking in the property buffer when parsing PCF files in libXfont2 ComputeScaledProperties before...
EulerOS 2.0 SP11 : xorg-x11-server (EulerOS-SA-2026-4388)
According to the versions of the xorg-x11-server packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A stack-based buffer overflow flaw was found in the X.Org X server and Xwayland. A mismatch between the X server and the libXfont2...
EulerOS 2.0 SP13 : libXfont2 (EulerOS-SA-2026-4149)
According to the versions of the libXfont2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A heap buffer overflow due to missing size checking in the property buffer when parsing PCF files in libXfont2 ComputeScaledProperties before...