105516 matches found
chromium-browser: angle: Google Chrome (ANGLE): Arbitrary Code Execution vulnerability
A flaw was found in ANGLE, a component of Google Chrome. This out-of-bounds write vulnerability allows a remote attacker to potentially execute arbitrary code. By tricking a user into visiting a specially crafted HTML page, an attacker could bypass the browser's security sandbox and execute...
xorg-x11-server: xorg-x11-server: arbitrary code execution via out-of-bounds write in XKB keycode handling
A flaw was found in xorg-x11-server. In the X Keyboard Extension XKB, key name memory is allocated with an insufficient buffer size compared to the maximum supported range. An authenticated local client can exploit this flaw by sending requests that modify the keycode range, triggering a heap-bas...
Important: Red Hat Security Advisory: xorg-x11-server security update
An update for xorg-x11-server is now available for Red Hat Enterprise Linux 9. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerabilit...
CVE-2026-111441
在 openGauss-server 的 src/gausskernel/cbb/utils/hll/hll.cpp 中,内置函数 HllObjectUnpack 存在长度校验缺陷。该函数从用户提供的 packed HLL 解析 lenUsed 与 lenTotal 后,仅检查输入长度足以覆盖 HLLHEADSIZE + lenUsed,随后按 lenTotal 分配缓冲区、按 lenUsed 调用 memcpys 拷贝输入,既未校验 lenTotal = lenUsed,也将 memcpys 目标大小写成 lenUsed 而非实际分配的...
chromium-browser: angle: Google Chrome (ANGLE): Arbitrary Code Execution vulnerability
A flaw was found in ANGLE, a component of Google Chrome. This out-of-bounds write vulnerability allows a remote attacker to potentially execute arbitrary code. By tricking a user into visiting a specially crafted HTML page, an attacker could bypass the browser's security sandbox and execute...
postgresql: PostgreSQL: Arbitrary code execution via integer wraparound in tsvector and tsquery functions
A flaw was found in PostgreSQL. An unprivileged database user can exploit an integer wraparound vulnerability in the tsvector and tsquery data type functions. By providing crafted large inputs, the server can be forced to undersize an allocation, leading to an out-of-bounds write. This could...
CVE-2026-111441 HLL 反序列化 lenTotal/lenUsed 校验缺失导致堆越界写
在 openGauss-server 的 src/gausskernel/cbb/utils/hll/hll.cpp 中,内置函数 HllObjectUnpack 存在长度校验缺陷。该函数从用户提供的 packed HLL 解析 lenUsed 与 lenTotal 后,仅检查输入长度足以覆盖 HLLHEADSIZE + lenUsed,随后按 lenTotal 分配缓冲区、按 lenUsed 调用 memcpys 拷贝输入,既未校验 lenTotal = lenUsed,也将 memcpys 目标大小写成 lenUsed 而非实际分配的...
EUVD-2026-104052
在 openGauss-server 的 src/gausskernel/cbb/utils/hll/hll.cpp 中,内置函数 HllObjectUnpack 存在长度校验缺陷。该函数从用户提供的 packed HLL 解析 lenUsed 与 lenTotal 后,仅检查输入长度足以覆盖 HLLHEADSIZE + lenUsed,随后按 lenTotal 分配缓冲区、按 lenUsed 调用 memcpys 拷贝输入,既未校验 lenTotal = lenUsed,也将 memcpys 目标大小写成 lenUsed 而非实际分配的...
CVE-2026-111441 HLL 反序列化 lenTotal/lenUsed 校验缺失导致堆越界写
在 openGauss-server 的 src/gausskernel/cbb/utils/hll/hll.cpp 中,内置函数 HllObjectUnpack 存在长度校验缺陷。该函数从用户提供的 packed HLL 解析 lenUsed 与 lenTotal 后,仅检查输入长度足以覆盖 HLLHEADSIZE + lenUsed,随后按 lenTotal 分配缓冲区、按 lenUsed 调用 memcpys 拷贝输入,既未校验 lenTotal = lenUsed,也将 memcpys 目标大小写成 lenUsed 而非实际分配的...
CVE-2026-111441
The openGauss-server software contains a heap-based buffer overflow vulnerability in the src/gausskernel/cbb/utils/hll/hll.cpp file. The root cause is a validation flaw within the HllObjectUnpack() function, which fails to verify that lenTotal is greater than or equal to lenUsed when unpacking us...
ALSA-2026:84799 Important: mariadb11.8 security update
MariaDB is a community developed fork from MySQL - a multi-user, multi-threaded SQL database server. It is a client/server implementation consisting of a server daemon mariadbd and many different client programs and libraries. The base package contains the standard MariaDB/MySQL client programs a...
CentOS Linux 8.5 [TuxCare] Security Update: rsync / rsync-daemon (CENTOS8.5:CLSA-2026:1792425174)
The CentOS Linux 8.5 host has packages installed that are affected by a vulnerability as referenced in the TuxCare CENTOS8.5:CLSA-2026:1792425174 advisory. - rsync 3.2.5 before 3.5.0 contains a heap out-of-bounds write vulnerability that allows remote unauthenticated attackers to write one...
RHEL 10 : kernel (RHSA-2026:85321)
The remote Redhat Enterprise Linux 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2026:85321 advisory. The kernel packages contain the Linux kernel, the core of any Linux operating system. Security Fixes: kernel: openvswitch: defer tunnel...
PT-2026-117406
RisingWave before 3.1.0 contains a missing authorization vulnerability that allows low-privileged SQL users to read and write arbitrary server files by creating posix fs sources and fs sinks. Attackers holding schema CREATE privilege can set posix fs.root or fs.path to any directory to read...
CVE-2026-12660: Improper Limitation of a Pathname to a Restricted Directory
IBM MQ Web Console could allow an authenticated administrator to write files outside the intended directory due to improper path validation...
PT-2026-117511
IBM MQ Web Console could allow an authenticated administrator to write files outside the intended directory due to improper path validation...
Linux Distros Unpatched Vulnerability : CVE-2026-98532
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - ipv6: do not let ipv6findhdr return an offset past the packet end ipv6findhdr walks the extension header chain, skipping each header by the length that header...
RHEL 8 : gimp:2.8 (RHSA-2026:84744)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2026:84744 advisory. The GIMP GNU Image Manipulation Program is an image composition and editing program. GIMP provides a large image manipulation toolbox,...
Linux Distros Unpatched Vulnerability : CVE-2026-112007
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Schism Tracker through 20260524 contains a heap out-of-bounds write vulnerability in fmtultloadsong in fmt/ult.c that fails to clamp the one-byte sample count t...
RockyLinux 8 : gimp:2.8 (RLSA-2026:84744)
The remote RockyLinux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2026:84744 advisory. gimp: gimp: out-of-bounds write in lighting effects plugin via crafted preset file CVE-2026-90947 gimp: gimp: heap-based buffer overflow in ICO loader v...