10 matches found
WordPress Post Snippets cross-site scripting vulnerability
WordPress Post Snippets versions 4.2.4 and earlier contain a cross-site scripting vulnerability. This flaw stems from insufficient input sanitization and output escaping. Authenticated attackers with contributor or higher privileges can exploit this by injecting arbitrary web scripts via shortcod...
WordPress Post Snippets – Custom WordPress Code Snippets Customizer plugin <= 4.2.4 - Authenticated (Contributor+) Stored Cross-Site Scripting vulnerability
Authenticated Contributor+ Stored Cross-Site Scripting vulnerability discovered by Wordfence PRISM in WordPress Plugin Post Snippets versions = 4.2.4...
WordPress Post Snippets plugin <= 4.2.4 - Contributor+ Stored XSS vulnerability
Contributor+ Stored XSS vulnerability discovered by Philipp Doblhofer in WordPress Plugin Post Snippets versions = 4.2.4...
CVE-2026-56049 WordPress Post Snippets plugin <= 4.0.19 - Remote Code Execution (RCE) vulnerability
Contributor Remote Code Execution RCE in Post Snippets = 4.0.19 versions...
WordPress Post Snippets plugin <= 4.0.19 - Remote Code Execution (RCE) vulnerability
Remote Code Execution RCE vulnerability discovered by daroo in WordPress Plugin Post Snippets versions = 4.0.19...
CVE-2026-25001
CVE-2026-25001 is a confirmed vulnerability in the WordPress plugin Post Snippets (formerly Post Snippets – Custom WordPress Code Snippets Customizer) affecting versions up to 4.0.12. The Wordfence entry characterizes the issue as a Remote Code Execution vulnerability requiring authenticated acce...
WordPress Post Snippets plugin <= 4.0.12 - Remote Code Execution (RCE) vulnerability
Remote Code Execution RCE vulnerability discovered by Doan Dinh Van in WordPress Plugin Post Snippets versions = 4.0.12...
CVE-2025-63040 WordPress Post Snippets plugin <= 4.0.11 - Cross Site Request Forgery (CSRF) vulnerability
Cross-Site Request Forgery CSRF vulnerability in Saad Iqbal Post Snippets post-snippets allows Cross Site Request Forgery.This issue affects Post Snippets: from n/a through = 4.0.11...
WordPress Post Snippets Plugin < 4.0.4 is vulnerable to Cross Site Scripting (XSS)
Software Post Snippets Type Plugin Vulnerable versions 4.0.4 Fixed in 4.0.4 OWASP Top 10 A3: Injection Classification Cross Site Scripting XSS CVE CVE-2023-33999 Patch priority Medium CVSS severity Medium 7.1 Developer Claim ownership PSID e4d64cbe7635 Credits Rafie Muhammad Patchstack Required...
WordPress Post Snippets Plugin <= 4.0.2 is vulnerable to Cross Site Scripting (XSS)
Software Post Snippets Type Plugin Vulnerable versions = 4.0.2 Fixed in 4.0.3 OWASP Top 10 A7: Cross-Site Scripting XSS Classification Cross Site Scripting XSS CVE CVE-2023-25459 Patch priority Low CVSS severity Low 5.9 Developer Claim ownership PSID db47be90330a Credits Abdi Pranata Required...